読者です 読者をやめる 読者になる 読者になる

たごもりすメモ

コードとかその他の話とか。

あれこれやってたらrakeの実行が失敗するようになった

ruby

OSXに入ってたruby 1.8.7を残しつつ1.9.2p0を使いたいなーとか両立させてたんだけど、Passengerとかがいい感じに混乱するようなので1.9オンリーに変えてしまおう。と思い立ったはいいが、あれこれいじってたらrakeがこんなエラーを出して動かなくなった。

dhcp79:yabitz tagomoris$ rake --version
/usr/local/lib/ruby/1.9.1/rubygems.rb:340:in `bin_path': can't find executable rake for rake-0.8.7 (Gem::Exception)
	from /usr/local/bin/rake:19:in `
' dhcp79:yabitz tagomoris$

おっかしーなー、とかあれこれぐぐってたら、こんなページが見付かった。
http://redmine.ruby-lang.org/issues/show/3677

やりとりを読んでその通りに、バージョン番号の入ってない rake.gemspec ファイルを削除すると回復。やれやれ……。